Wednesday, January 20, 2010

Re: Iterating over a QuerySet

On Jan 20, 7:09 pm, Olivier Guilyardi <m...@xung.org> wrote:
> For best performances, should I:
>
> records = MyModel.objects.all()
> for item in records:
>     ...
>
> or is the following ok:
>
> for item in MyModel.objects.all():
>     ...
>
> ?

There is no difference, except for the infinitesimal amount of time
for the extra variable lookup. The only difference is readability, or
if you need to use the same queryset again.
--
DR.

0 Comments:

Post a Comment

Subscribe to Post Comments [Atom]

<< Home


Real Estate